Page 56 / 196 Scroll up to view Page 51 - 55
4-10
Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
OL-5332-01
Chapter 4
Configuring PPP over ATM with NAT
Configure Network Address Translation
Step 4
ip nat
{
inside | outside
}
Example:
Router(config-if)#
ip nat inside
Router(config-if)#
Applies NAT to the Fast Ethernet LAN interface
as the inside interface.
For details about this command and additional
parameters that can be set, as well as information
about enabling static translation, see the
Cisco IOS IP Command Reference, Volume 1 of 4:
Addressing and Services
.
Step 5
no shutdown
Example:
Router(config-if)#
no shutdown
Router(config-if)#
Enables the configuration changes just made to the
Ethernet interface.
Step 6
exit
Example:
Router(config-if)#
exit
Router(config)#
Exits configuration mode for the Fast Ethernet
interface.
Step 7
interface
type number
Example:
Router(config)#
interface atm 0
Router(config-if)#
Enters configuration mode for the ATM WAN
interface (ATM0) to be the outside interface for
NAT.
Step 8
ip nat
{
inside | outside
}
Example:
Router(config-if)#
ip nat outside
Router(config-if)#
Identifies the specified WAN interface as the NAT
outside interface.
For details about this command and additional
parameters that can be set, as well as enabling
static translation, see the
Cisco IOS IP Command
Reference, Volume 1 of 4: Addressing and
Services
.
Step 9
no shutdown
Example:
Router(config-if)#
no shutdown
Router(config-if)#
Enables the configuration changes just made to the
Ethernet interface.
Command
Purpose
Page 57 / 196
4-11
Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
OL-5332-01
Chapter 4
Configuring PPP over ATM with NAT
Configuration Example
Note
If you want to use NAT with a virtual-template interface, you must configure a loopback interface. See
Chapter 1, “Basic Router Configuration,”
for information on configuring the loopback interface.
For complete information on NAT commands, see the Cisco IOS Release 12.3 documentation set. For
more general information on NAT concepts, see
Appendix B, “Concepts.”
Configuration Example
The following configuration example shows a portion of the configuration file for a client in the PPPoA
scenario described in this chapter.
The VLAN interface has an IP address of 192.168.1.1 with a subnet mask of 255.255.255.0. NAT is
configured for inside and outside.
Note
Commands marked by “
(default)
” are generated automatically when you run the
show running-config
command.
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly (
default
)
!
interface ATM0
no ip address
ip nat outside
ip virtual-reassembly
no atm ilmi-keepalive
pvc 8/35
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
dsl operating-mode auto
!
Step 10
exit
Example:
Router(config-if)#
exit
Router(config)#
Exits configuration mode for the ATM interface.
Step 11
access-list
access-list-number
{
deny
|
permit
}
source
[
source-wildcard
]
Example:
Router(config)#
access-list 1
permit
192.168.1.0 255.255.255.0
Defines a standard access list permitting addresses
that need translation.
Note
All other addresses are implicitly denied.
Command
Purpose
Page 58 / 196
4-12
Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
OL-5332-01
Chapter 4
Configuring PPP over ATM with NAT
Configuration Example
interface Dialer0
ip address negotiated
ip mtu 1492
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap
!
ip classless (
default
)
!
ip nat pool pool1 192.168.1.0 192.168.2.0 netmask 0.0.0.255
ip nat inside source list 1 interface Dialer0 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
dialer-list 1 protocol ip permit
ip route 10.10.25.2 0.255.255.255 dialer 0
!
Verifying Your Configuration
Use the
show ip nat statistics
command in privileged EXEC mode to verify the PPPoA client with NAT
configuration. You should see verification output similar to the following example:
Router#
show ip nat statistics
Total active translations: 0 (0 static, 0 dynamic; 0 extended)
Outside interfaces:
ATM0
Inside interfaces:
Vlan1
Hits: 0
Misses: 0
CEF Translated packets: 0, CEF Punted packets: 0
Expired translations: 0
Dynamic mappings:
-- Inside Source
[Id: 1] access-list 1 interface Dialer0 refcount 0
Queued Packets: 0
Page 59 / 196
C H A P T E R
5-1
Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
OL-5332-01
5
Configuring a LAN with DHCP and VLANs
The Cisco 870 series routers support clients on both physical LANs and virtual LANs (VLANs). The
routers can use the Dynamic Host Configuration Protocol (DHCP) to enable automatic assignment of IP
configurations for nodes on these networks.
Figure 5-1
shows a typical deployment scenario with two physical LANs connected by the router and
two VLANs.
Figure 5-1
Physical and Virtual LANs with DHCP Configured on the Cisco Router
92339
1
2
3
4
1
Fast Ethernet LAN (with multiple networked devices)
2
Router and DHCP server—Cisco 870 series access router—connected to the Internet
3
VLAN 1
4
VLAN 2
DHCP
DHCP, which is described in RFC 2131, uses a client/server model for address allocation. As an
administrator, you can configure your Cisco 800 series router to act as a DHCP server, providing IP
address assignment and other TCP/IP-oriented configuration information to your workstations. DHCP
frees you from having to manually assign an IP address to each client.
Page 60 / 196
5-2
Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
OL-5332-01
Chapter 5
Configuring a LAN with DHCP and VLANs
Configure DHCP
When you configure a DHCP server, you must configure the server properties, policies, and DHCP
options.
Note
Whenever you change server properties, you must reload the server with the configuration data from the
Network Registrar database.
VLANs
The Cisco 870 series access routers support four Fast Ethernet ports on which you can configure
VLANs.
VLANs enable networks to be segmented and formed into logical groups of users, regardless of the
user’s physical location or LAN connection.
Configuration Tasks
Perform the following tasks to configure this network scenario:
Configure DHCP
Configure VLANs
Note
The procedures in this chapter assume you have already configured basic router features as well as
PPPoE or PPPoA with NAT. If you have not performed these configurations tasks, see
Chapter 1, “Basic
Router Configuration,” Chapter 3, “Configuring PPP over Ethernet with NAT,”
and
Chapter 4,
“Configuring PPP over ATM with NAT”
as appropriate for your router.
Configure DHCP
Perform these steps to configure your router for DHCP operation, beginning in global configuration
mode:
Command
Purpose
Step 1
ip domain name
name
Example:
Router(config)#
ip domain name smallbiz.com
Router(config)#
Identifies the default domain that the router uses to
complete unqualified hostnames (names without a
dotted-decimal domain name).
Step 2
ip name-server
server-address1
[
server-address2...server-address6
]
Example:
Router(config)#
ip name-server 192.168.11.12
Router(config)#
Specifies the address of one or more Domain Name
System (DNS) servers to use for name and address
resolution.

Rate

4.5 / 5 based on 2 votes.

Bookmark Our Site

Press Ctrl + D to add this site to your favorites!

Share
Top