Page 101 / 196 Scroll up to view Page 96 - 100
9-5
Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
OL-5332-01
Chapter 9
Configuring a Wireless LAN Connection
Configure Bridging on VLANs
Repeat
Step 2
through
Step 7
above for each VLAN that requires a wireless interface.
Step 3
bridge-group
number
Example:
Router(config)#
bridge-group 1
Router(config)#
Assigns a bridge group to the interface.
Step 4
bridge-group
number parameter
Example:
Router(config)#
bridge-group 1
spanning-disabled
Router(config)#
Sets other bridge parameters for the bridging
interface.
Step 5
interface
name number
Example:
Router(config)#
interface bvi 1
Router(config)#
Enters configuration mode for the virtual bridge
interface.
Step 6
bridge
number
route
protocol
Example:
Router (config) #
bridge 1 route ip
Router(config)#
Specifies the protocol for the bridge group.
Step 7
ip address
address mask
Example:
Router(config)#
ip address 10.0.1.1
255.255.255.0
Router(config)#
Specifies the address for the virtual bridge
interface.
Command or Action
Purpose
Page 102 / 196
9-6
Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
OL-5332-01
Chapter 9
Configuring a Wireless LAN Connection
Configure Radio Station Subinterfaces
Configure Radio Station Subinterfaces
Perform these steps to configure subinterfaces for each root station, beginning in global configuration
mode:
Command
Purpose
Step 1
interface
type number
Example:
Router(config)#
interface dot11radio 0.1
Router(config-subif)#
Enters subinterface configuration mode for the
root station interface.
Step 2
description
string
Example:
Router(config-subif)#
description Cisco open
Router(config-subif)#
Provides a description of the subinterface for the
administrative user.
Step 3
encapsulation dot1q
vlanID
[
native
|
second-dot1q
]
Example:
Router(config-subif)#
encapsulation dot1q 1
native
Router(config-subif)#
Specifies that IEEE 802.1Q (dot1q)
encapsulation is used on the specified
subinterface.
Step 4
no cdp enable
Example:
Router(config-subif)#
no cdp enable
Router(config-subif)#
Disables the Cisco Discovery Protocol (CDP) on
the wireless interface.
Page 103 / 196
9-7
Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
OL-5332-01
Chapter 9
Configuring a Wireless LAN Connection
Configuration Example
Repeat these steps to configure more subinterfaces, as needed.
Configuration Example
The following configuration example shows a portion of the configuration file for the wireless LAN
scenario described in the preceding sections.
!
bridge irb
!
interface Dot11Radio0
no ip address
!
broadcast-key vlan 1 change 45
!
!
encryption vlan 1 mode ciphers tkip
!
ssid cisco
vlan 1
authentication open
wpa-psk ascii 0 cisco123
authentication key-management wpa
!
ssid ciscowep
vlan 2
authentication open
!
ssid ciscowpa
vlan 3
authentication open
Step 5
bridge-group
number
Example:
Router(config-subif)#
bridge-group 1
Router(config-subif)#
Assigns a bridge group to the subinterface.
Note
When the bridge-group command is
enabled, the following commands are
automatically enabled, and cannot be
disabled. If you disable these commands
you may experience an interruption in
wireless device communication.
bridge-group 1
subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1
block-unknown-source
Step 6
exit
Example:
Router(config-subif)#
exit
Router(config)#
Exits subinterface configuration mode, and
enters global configuration mode.
Command
Purpose
Page 104 / 196
9-8
Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
OL-5332-01
Chapter 9
Configuring a Wireless LAN Connection
Configuration Example
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
rts threshold 2312
power local cck 50
power local ofdm 30
channel 2462
station-role root
!
interface Dot11Radio0.1
description Cisco Open
encapsulation dot1Q 1 native
no cdp enable
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio0.2
encapsulation dot1Q 2
bridge-group 2
bridge-group 2 subscriber-loop-control
bridge-group 2 spanning-disabled
bridge-group 2 block-unknown-source
no bridge-group 2 source-learning
no bridge-group 2 unicast-flooding
!
interface Dot11Radio0.3
encapsulation dot1Q 3
bridge-group 3
bridge-group 3 subscriber-loop-control
bridge-group 3 spanning-disabled
bridge-group 3 block-unknown-source
no bridge-group 3 source-learning
no bridge-group 3 unicast-flooding
!
interface Vlan1
no ip address
bridge-group 1
bridge-group 1 spanning-disabled
!
interface Vlan2
no ip address
bridge-group 2
bridge-group 2 spanning-disabled
!
interface Vlan3
no ip address
bridge-group 3
bridge-group 3 spanning-disabled
!
interface BVI1
ip address 10.0.1.1 255.255.255.0
!
interface BVI2
ip address 10.0.2.1 255.255.255.0
!
interface BVI3
ip address 10.0.3.1 255.255.255.0
!
Page 105 / 196
C H A P T E R
10-1
Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
OL-5332-01
10
Sample Configuration
This chapter collects the results of the Ethernet WAN interface, DHCP, VLAN, Easy VPN, and wireless
interface configurations made in previous chapters. This allows you to view what a basic configuration
provided by this guide looks like in a single sample,
Example 10-1
.
Note
Commands marked by “(
default
)” are generated automatically when you run the
show running-config
command.
Example 10-1
Sample Configuration
Router#
show running-config
Building configuration...
Current configuration : 3781 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname retail
!
boot-start-marker
boot-end-marker
!
enable password cisco123
!
username jsomeone password 0 cg6#107X
aaa new-model
!
aaa group server radius rad_eap
server 10.0.1.1 auth-port 1812 acct-port 1813
!
aaa authentication login eap_methods group rad_eap
aaa session-id common
ip subnet-zero
ip cef
!
vpdn enable
vpdn-group 1
request-dialin
protocol pppoe
!

Rate

4.5 / 5 based on 2 votes.

Bookmark Our Site

Press Ctrl + D to add this site to your favorites!

Share
Top